Newest pip Questions

Q&A for professional and enthusiast programmers

how to use pip to install pkg from requirement file without reinstall

I am trying to build an Docker image. My Dockerfile is like this: FROM python:2.7 ADD . /code WORKDIR /code RUN pip install -r requirement.txt CMD ["python", "manage.py", "runserver", "0.0.0.0:8300"] ...

Pip Error python

I've got an error when I would like to get pip upgrade or to install a package. I know that my answer could be in this forum, but I don't find it. So my error is : Exception: Traceback (most ...

Can not install numpy using pip in Python3, Ubuntu14.04

i'm getting this error when trying pip install numpy : pip is configured with locations that require TLS/SSL, however the ssl module in Python is not available. Collecting numpy Could not fetch URL ...

numpy intalled with pip but not found (in virtualenv)

In an AWS EC2 instance, with Amazon Linux AMI 2016.09 distribution, I have installed numpy, inside my virtualenv where python 3.4 is the default version, with: pip install numpy It installs package ...

Installation of tensor flow on windows

When I installed tensor flow, after type following command pip3 install --upgrade tensor flow following issue rose up Could not find a version that satisfies the requirement tensor flow (from ...

Pip install Scrapy “codec can't decode byte”

I'm trying hard to install Scrapy, first time I tried I've get error about vcvarsall.bat, I was trying some solutions but nothing worked so I reinstall Visual Studio Community 2017 and dev tools, and ...

Python 3 cannot import just installed module on Windows

pip3 failed to install the Image module, therefore I have followed an alternative procedure, but then Python cannot import the module. Here is what I have done: C:\Users\myuser>pip3 install --...

Why does pip install requirements.txt install extra packages?

I have a repository with an inflated requirements.tx that I'd like to clean up. Using pipreqs I've set my requirements.txt to be a minimal set of packages need for my repository. To test this, I setup ...

Pip: Could not fetch URL for pypi and issue confirming the ssl certificate

I recently just installed python(3.6.1) which is running pip(9.0.1) and I get the following error anytime I try to install a package: pip install cx_Oracle Collecting cx_Oracle Could not fetch URL ...

create requirements.txt for scripts folder

I need create a requierment.txt for all scripts in specific folder(s). For your informations, scripts are used by an other program and run inside it... I can't use venv because program use it own ...

How do I install pyOpt on Mac using anaconda?

I used conda install -c mutirri pyopt=1.2.0 to install pyOpt on my Mac computer based on this. However, I got this error in my terminal: $ conda install -c mutirri pyopt=1.2.0 Fetching package ...

Why do pip list and pip.get_installed_distributions() disagree?

I try use pip for all my Python package installations, have somehow gotten myself out of synch. When I try to list the pip installed packages using pip list, I do not see a mayavi package. However, ...

ImportError for entry_points in setup.py

I get an ImportError: No module named 'test.nested' when I try to call a console script entry point defined in my setup.py. Project structure: test ├── setup.py └── test    ├── __init__.py    └── ...

mac os zsh: command not found: pip

I'm learning python and some article tell me that I should use pip, but when I trying to install pip success, it tells me zsh: command not found: pip this is my python ➜ ~ git:(master) ✗ which -a ...

What is the purpose “pip install --user …”?

From pip install --help: --user Install to the Python user install directory for your platform. Typically ~/.local/, or %APPDATA%\Python on Windows. (See the Python documentation ...

How to install pyjnius on Ubuntu 16.04 using pip 9.0.1?

I have problems with pip 9.0.1 and pyjnius. root@pluto:~# pip list --format=columns | grep pip pip 9.0.1 root@pluto:~# pip install pyjnius Collecting pyjnius Could ...

Embedded Python 3.5 “python setup.py egg_info” failed with error code 1

I am attempting to "pip install" PyAutoGUI ( among other modules ) and I am getting the following error : Collecting pyautogui Using cached PyAutoGUI-0.9.35.zip Complete output from command ...

Python Twisted twisted.internet

I've downloaded twisted from git git clone -b trunk https://github.com/twisted/twisted.git as http://twistedmatrix.com/trac/wiki/Downloads suggests. And then I performed sudo python setup.py ...

Python: Can't install .whl package for two python versions on Windows

I have Python 2.7 and 3.4 on my work computer for compatibility reasons with older scripts. Now I wanted to install "aenum" for Py2.7 but "pip" only installs the package for Py3.4. telling me "aenum-...

Pip install Boxsdk with JWT Oath not functioning as expected

This is a pretty straightforward question I am hoping someone can help explain. In the boxsdk repo they give a quick example how to set up boxsdk with JWT OAth. (https://github.com/box/box-python-sdk)...

python 2.7 bcrypt not found after pip already satisfied

me@localhost:# sudo pip install bcrypt Requirement already satisfied (use --upgrade to upgrade): bcrypt in /usr/local/lib/python2.7/dist-packages Requirement already satisfied (use --upgrade to ...

Failed to install wsgiref on Mac

I have a problem on install wsgiref on Mac. $ python --version Python 3.6.0 :: Anaconda 4.3.1 (x86_64) $ pip --version pip 9.0.1 from /anaconda/lib/python3.6/site-packages (python 3.6) My ...

M2Crypto RSA Alternative method for read key

Actually i read a .pem file with M2Crypto RSA, all works fine but becase the virtual enviroment and the incompatibility of this on SSLv2_method on Ubuntu and Gunicorn i need to read and sign with the ...

Installation using python

How can I install a list of executable files in sequence, having multistep installation? Every file has different steps for its installation, for example, I need to click on License agreement ("I ...

Python 3.6 windows cannot use packages installed from pip

I cannot use any packages installed using pip on python, it says no such package as x installed despite when listing packages using help('modules') it lists package x as installed. Package trying to ...

beautifulsoup4 does not support python 3

from bs4 import BeautifulSoup Traceback (most recent call last): File "<pyshell#11>", line 1, in <module> from bs4 import BeautifulSoup File "C:\Users\Jerome Sam\AppData\Local\...

Error installing tensorflow

I am trying to install tensorflow with the pip in the cmd, but it is appearing an error "could not find the version that satisfies the requirement tensorflow" I have the phyton 3.5 version installed ...

Best way to include generated files into python distribution

I am building a package which is to be installed through pip via an internal index. My documentation is in Markdown format, but I would like the distribution to have a rendered HTML for ease of use. ...
+500

Why is docker looking in /simple for python packages?

I've been trying to get django to run via uwsgi in a docker container. I had django running in docker, with its built in web server, but now that I've modified the requirements.txt to include uwsgi, ...

Unable to install kur on win10 due to scipy

I'm trying to install kur on my laptop running windows 10 and when installing files, it needs scipy 0.18.1, which it is unable to install. With a bit of googling, it seems that scipy cannot be ...

running `print(sys.platform)` in the plain Python interpreter yielded a blank string

Running print(sys.platform) in the plain Python interpreter yielded a blank string I try to configure the code of an open source python project on github..I installed the program with pip install and ...

pip install hangs on linux

I am trying to pip install pymssql on a linux. However, this is what I get and not sure why pip hangs here and also characters get garbled. Would you please give any advice? [admin@hostname ~]$pip ...

Upgrade pip on Pycharm

I want to upgrade pip 7.1.2 to pip 9.0.1, how can I do it? I am using Python on Windows 10. I tried using the command- -m pip install --upgrade pip

I'm trying to use pip to install pyinstaller but it's giving me this error: ImportError: No module named 'bz2'

I reinstalled all python versions I have (2.7, 3.4 and 3.6) and I'm not getting the 'encodings" error anymore, but another problem took it's place. I'm trying to install pyinstaller, I run pip ...

pip3 MESSED UP (thanks to openCV)

My main goal was to download and install openCV3 for python3.6 to do some image processing. I never got it to work, I don't know why opencv is so difficult to get working even with homebrew. Anyways ...

python2.7 install python daemon package using pip

When I try to install python daemon package I get this error all the time (installation tried by using pip command & downloading the archive and using pip to install): pip install python-daemon-2....

Not able to install/uninstall packages using python pip

When I tried to install or uninstall packages using pip(with or without using sudo), I am getting Exception. Exception: Traceback (most recent call last): File "/Library/Python/2.7/site-packages/...

Install only the required packages that are not on a different machine

I have cloned my Django project from GitHub to my different machine. The other machine already has some of the latest python packages installed (eg Django v1.10.6), whereas in the requirements.txt ...

How to force pip uninstall in case of missing files

I need to remove a corrupted old version of setuptools package from pip unfortunately pip uninstall setuptools doesn't work because cannot find some entries and returns me: Cannot remove entries ...

How to get z3 in pycharm?

I just thought I should try out pycharm and z3 theorem prover but I am having a hard time setting it up. Method 1 I am running Windows 8, and my first try was to install the z3 package via pycharm (...

Clone a virtualenv without use pip freeze

I'm working with a virtualenviroment that don't have a downloads for some modules, so doing pip freeze > requirements.txt and then pip install -r requirements.txt won't work. There's a way to avoid ...

Installing arpack for python with pip - NotFoundError,'no lapack/blas resources found'

I'm trying to install ARPACK for python 3.5 through PyCharm. for pip install --user arpack I get: Collecting arpack Using cached arpack-0.0.0.tar.gz Complete output from command ...

Segmentation fault when re-installed pip

I tried to uninstall python3-pip hoping to install a pip that works for python2.7. But after the installation it always shows segmentation fault. Here is what I did: My system is Opensuse 13.2 and I ...

Can't install package because of Old Command in Setup.Py

I'm trying to use pip to install a package but get the following error output. I'm aware that decode is no longer used in Python 3.x (I'm using 3.6) and am not sure how to get the file to install. ...

Python - Install a CLI utility with pip for being usable not just with virtual environments

Suppose a CLI utility published in PyPI, downloadable with pip. I want to install it for being usable not inside a virtual environment. With a virtual environment, the entrypoint script is being ...

ubuntu16.04 cannot install progreebar for python

When I tried to install progressbar for python3.5, I met an error: I use sudo pip install progressbar It shows: Collecting progressbar Downloading progressbar-2.3.tar.gz Complete output from ...

Wrong pip3 version

I installed my python3.5.1 with Anaconda but the pip3 version is wrong and the package installation location is wrong. pip3 --version pip 9.0.1 from /Users/Ruidong/anaconda/lib/python2.7/site-...

pip freeze not listing all dependencies for virtualenv

I have a python project that uses virtualenv. I have installed various packages using pip install <package-name> with the virtual environment activated. I now want to generate a list of these ...

Pip: could not find a version. No matching distribution found

I'm trying to install Flask-ACL: https://mikeboers.github.io/Flask-ACL $ pip search acl | grep -i flask Flask-ACL (0.0.1) - Access control lists for Flask. flask-miracle-acl (0.2) - The fabric ...

Create a pip package for different versions of Python

I have a rather large chunk of code written in Python 2.7. My end goal is to have working versions in both Python 2 and 3, both install-able via pip and available on GitHub. What are the standard ...
Translating... 0%